Probleme mit Kompassmodul

Alles über die Elektronik.
Antworten
MOS6581
Beiträge: 7
Registriert: 19. Mai 2020, 08:17

Probleme mit Kompassmodul

Beitrag von MOS6581 »

Moin,

nachdem meine mechanische Dauerbaustelle nun für's erste fertig ist, widme ich mich jetzt den Sensoren.
Das Kompassmodul ist fertig angebunden und wird auch erkannt. Nehme ich das Modul in die Hand und drehe es, werden auch plausible Werte in der App angezeigt. Sobald ich den Kompass aber am Mäher befestige und manuell etwas herumfahre, bekomme ich nur einen kleinen Wertebereich (200-230) angezeigt. Mir scheint, als würde irgendetwas das Magnetfeld stören, ich tippe hier auf die Fahrmotoren.

Hat noch jemand Probleme mit dem Kompass?

Danke und viele Grüße,
MOS

bkramer
Site Admin
Beiträge: 38
Registriert: 14. Mai 2020, 16:48

Re: Probleme mit Kompassmodul

Beitrag von bkramer »

Die Einbaulage ist wichtig.
IMG_0527.jpg
IMG_0527.jpg (147.46 KiB) 198 mal betrachtet
Der Kompass reagiert ebenfalls auf alles, was aus Metall ist.
Ich habe ihn ganz am Ende etwas höher angebracht.

Willy
Beiträge: 2
Registriert: 29. Jun 2020, 10:42

Re: Probleme mit Kompassmodul

Beitrag von Willy »

Hallo, bei mir nimmt die Kompassanzeige in der App wahllos alle möglichen Werte zwischen 0 und 360 Grad an. Der Kompass steht in diesem Moment still und es dreht sich kein Motor. Ich habe schon beide Kompassarten eingestellt, jedoch brachte dies keinen Erfolg. Weiterhin möchte ich das Kompasskabel um ca. 1m verlängern, wenn ich aber den Meter dazwischen stecke, dann aktualisiert sich der Richtungswert nur noch sporadisch alle paar Sekunden - mal davon abgesehen, dass die Richtung nicht stimmt. Auch der Wert der Stromstärke steht in der App still bei 14,3 A und die Spannung über 200V. Fahren lässt sich der Mäher wunderbar per App - momentan noch manuell. Hat jemand ähnliche Probleme und besser noch die Lösungen?

Gruß,
Willy

Antworten